Василиса▶ Я жду вашего обращения. Что Вы хотите узнать?
Логотип
Project:Support desk - MediaWiki Project:Support desk About this board Edit description

[}" data-mw="{"parts":[{"template":{"target":{"wt":"Project:Support desk/Header/{{#ifexist::Project:Support desk/Header/{{int:lang}}|{{int:lang}}|en}}","href":"./Project:Support_desk/Header/en"},"params":{},"i":0}}]}"> Welcome to the MediaWiki Support desk, where you can ask MediaWiki questions!

( Read this message in a different language )

See also Other places to ask for help: Chat rooms Wikimedia Chat (Mattermost) MediaWiki unofficial (Discord) Outreachy chat (Zulip) Hackathon chat - (Telegram @wmhack group) Email groups StackOverflow (third-party) Unofficial MWUsers forum (third-party)Before you postCheck the basic How does MediaWiki work? guide.Check the FAQ and Errors and symptoms .If your question is about a specific feature, check the relevant technical manual , end-user help or extension page and consider asking on its talk page .For issues about the mediawiki.org website, report to Current issues instead.For trying out wiki editing, use the Sandbox instead.Post a new questionTo help us answer your questions, please indicate which versions you are using, as found on your wiki's Special:Version page: MediaWiki versionPHP versionDatabase type and versionPlease include the web address (URL) to your wiki if possible. It's often easier for us to identify the source of the problem if we can see the error directly.To start a new thread, click "Start a new topic".

Text is available under the Creative Commons Attribution-ShareAlike License ; additional terms may apply. See Terms of Use for details.

Start a new topic
How do I know if I am a member? 2 comments • 07:29, 14 April 2021 6 minutes ago 2 Edit title History Permalink Summarize 2600:1700:EE90:2890:B49B:3A23:90CD:26FD ( talk contribs )

Neither my email address or my name is coming up anywhere I try to enter it. However, this was years ago and I may have had a different email address which I do not remember. Can ANYONE help me? These help pages might as well be in Swahili!

I cannot log in, because the site will not accept my name or email addresses, so I am adding my email address here. mrdoolin1@yahoo.com.

Thank you so much!

Reply 07:10, 14 April 2021 25 minutes ago Permalink Malyacko ( talk contribs )

Welcome to the support desk for the MediaWiki software. Which website is that about? Member of what exactly?

Reply 07:29, 14 April 2021 6 minutes ago Permalink Reply to "How do I know if I am a member?" MediaWiki does not load at all 7 comments • 06:20, 14 April 2021 1 hour ago 7 Summary by Amfidiusz

Some PHP process got looped, server support managed to kill it. No logs to determine whats happened.

Edit title History Permalink Edit the topic summary Amfidiusz ( talk contribs )

Hello,


I have encountered the first issue with my MadiaWiki installation. I was playing with Vector.CSS file yesterday when the site stopped loading. At all. It doesn not show any errors or misconfiguration alerts, it just keeps endlessly loading. I tried different pages, other than main page, still the same. I removed all extra extensions and rss whitelist form LocalSettings.php, still the same. Tried different devices and browsers. I placed a custom .html file in the main directory and it was accessible, it's not a domain problem. I tried Manual:How to debug but the files is not being written as nothing loads. Same with browser console, it's empty.


What my be the issue there?


While creating this thread I received a reply from my server helpdesk. They claim the PHP process got looped and caused the site not able to run. They attached a screenshot with the lsphp73 process endlessly running. Possible MediaWiki bug or misconfiguration in my files?

Reply Edited 09:06, 1 November 2020 5 months ago Permalink Bawolff ( talk contribs )

it would be interesting to know what you put in the css. Ideally it would be good to know where mediawiki is stuck.


Try running manual:runJobs.php from the commandline (does it work?). You could try seeing if the api (especially actual api not the doc page) works and remove whatever you added to the css. You could also try manual:edit.php to edit from commandline.

Reply 10:19, 1 November 2020 5 months ago Permalink Amfidiusz ( talk contribs )

Thanks! I don't have access tothe commandline, it's a shared hosting.

I played with vector.css and mobile.css styles doing some minor changes to the background or font colors. I also placed my infoboxes styles in common.css. After the support broke the loop, they are accessible here:

https://wiki.starfield.pl/wiki/MediaWiki:Vector.css https://wiki.starfield.pl/wiki/MediaWiki:Mobile.css

https://wiki.starfield.pl/wiki/MediaWiki:Mobile.css (should be same as vector.css)

https://wiki.starfield.pl/wiki/MediaWiki:Common.css

Is there a way to avoid that issue in the future?

Reply 11:33, 1 November 2020 5 months ago Permalink MarkAHershberger ( talk contribs )

Without knowing what happened, it is hard to know how to avoid it. If it does happen again, please raise the issue with us and we'll try to get some more information. Logs would be good.

Reply 17:31, 1 November 2020 5 months ago Permalink Bawolff ( talk contribs )

maybe it could be an i18n recache event that somehow got stuck, but that doesnt quite sound right (if so adjusting manual:$wgCacheDirectory to somewhere writable might help). Really impossible to know without knowing what happened.

Reply 18:29, 1 November 2020 5 months ago Permalink Amfidiusz ( talk contribs )

Thank you, gentlemen! I will address my issue here next time it happens before contacting the server support desk. The last four days were alright, nothing has happened. Cheers!

Reply 18:20, 5 November 2020 5 months ago Permalink PaulLCarter ( talk contribs )

I have the same problem, but managed to work around it. When running ImportTextFiles.php, after about 10-20 files, the upload would loop (not progressing) without an error and memory/cpu would climb indefinitely.

My work-around is to call the script with one file at a time and add a 4 second sleep interval between each call. It has been working reliably that way for the last couple of hours.


I think there's an issue in ImportTextFiles with async handling of page updates. If the updates occur too quickly and the machine, DB or disk IO are too slow, then some sub-function is returning success to the ImportTextFiles.php program without actually completing the task. This needs to be changed so that updates are synchronous.

Reply 06:20, 14 April 2021 1 hour ago Permalink Reply to "MediaWiki does not load at all" Run All Cache Invalidations One comment • 00:55, 14 April 2021 6 hours ago 1 Edit title History Permalink Summarize Jabowery ( talk contribs )

How does one run all cache invalidations subsequent to updating a template?

I'm making extensive use of templates to simulate what might be thought of as a "Documented Spreadsheet" and can't afford to present invalid cached HTML after an update. Moreover, I don't want to recalculate all HTML cached pages after an update since many pages may have fallen into obsolescence but not yet been deleted for historical purposes.

Reply 00:55, 14 April 2021 6 hours ago Permalink Reply to "Run All Cache Invalidations" Trouble configuring the upload directory. One comment • 00:11, 14 April 2021 7 hours ago 1 Edit title History Permalink Summarize TheAutomaticc ( talk contribs )

I have sat here for hours trying to research this problem extensively and am back to square 1. I have followed the examples

on the previous pages to no avail.

I have an issue similar to the one I found from Adba.swht 4 years ago. (Unable to display file in Mediawiki)

The problem is that files upload are being created at the root folder for some reason.

Here is what i have in the Localsettings.php file.

$wgUploadDirectory = "$IP/images";

$wgUploadPath = "$wgScriptPath/images";

If I change it to $wgUploadPath = "/inetpub/wwwroot/mediawiki/images";

I get the following error message:

Action failed

Could not open lock file for "mwstore://local-backend/local-public/e/eb/ABCover.jpg". Make sure your upload directory is configured correctly and your web server has permission to write to that directory.

See https://www.mediawiki.org/wiki/Special:MyLanguage/Manual:$wgUploadDirectory for more information.

I changed the upload path to $wgUploadDirectory = "/mediawiki2/images";

just to verify it is being created and sure enough at C:\mediawiki2\images

the files are created. ie. /f/ff/testimage.jpg

Its not that the files dont upload, its that when they do then

1. The file itself cannot be found

2. The thumbnail fails to render (Error creating thumbnail: File missing)

Also, the system temp folder keeps creating phpXXX.tmp files

this is probably related so I figured its worth mentioning.

As stated before I have tried several examples but nothing seems to work.

Any and all help would be GREATLY appreciated.

Thank you in advance.

Reply 00:11, 14 April 2021 7 hours ago Permalink Reply to "Trouble configuring the upload directory." Forgotten password with no email 3 comments • 22:55, 13 April 2021 8 hours ago 3 Edit title History Permalink Summarize 109.213.7.154 ( talk contribs )

Hi,

I'd like to start re-using my old Wikipedia account which I made in 2014 and haven't used since 2016ish. My password doesn't seem to work. I tried resetting the password but that doesn't seem to work either, I don't receive any email; I don't know if I ever attached the account to a specific email address, maybe I didn't.

The account is called {"k":"1"},"dsr":[352,378,null,null]}" data-mw="{"parts":[{"template":{"target":{"wt":"FlowMention","href":"./Template:FlowMention"},"params":{"1":{"wt":"Liberivore"}},"i":0}}]}"> @ Liberivore and apparently still exists.

Any chance of getting it back or is it dead and gone and I should make a new account?

Thank you for any assistance.

Reply 14:36, 13 April 2021 16 hours ago Permalink Malyacko ( talk contribs )

If you find a way to absolutely surely prove that you are the very same person who also once created that very account, then please share more info.

Reply 16:09, 13 April 2021 15 hours ago Permalink 109.213.7.154 ( talk contribs )

Hi,

If it has an email address associated with it, my name is in that address.

If not, I found the list of contributions from that account ( https://en.wikipedia.org/w/index.php?title=Special:Contributions/Liberivore&dir=prev&offset=20150422203729&target=Liberivore ). One of the very first edits is to the page of my high school and, a few years later, that of my university and that of my senator. I'd be able to prove all of those things individually. I don't know if that's sufficient though as there could hypothetically be someone with very similar life-interests.

Thanks

L

Reply 17:02, 13 April 2021 14 hours ago Permalink Reply to "Forgotten password with no email" Move the images folder 4 comments • 21:24, 13 April 2021 10 hours ago 4 Edit title History Permalink Summarize Sokote zaman ( talk contribs )

Hello I installed the wiki from scratch and replaced the new 5GB photo folder The previous wiki is 1.35 with the current one Everything is fine but does not call photos Also, Special:ListFiles is nothing

Reply 16:28, 13 April 2021 15 hours ago Permalink Sokote zaman ( talk contribs )

I'm disappointed in your guidance. Is it permissible to take more than 1,000 photos from Wikiman and transfer it to The Destination Wiki? {"k":"1"},"dsr":[139,164,null,null]}" data-mw="{"parts":[{"template":{"target":{"wt":"FlowMention","href":"./Template:FlowMention"},"params":{"1":{"wt":"Jonathan3"}},"i":0}}]}"> @ Jonathan3

Reply 21:24, 13 April 2021 10 hours ago Permalink Jonathan3 ( talk contribs )

The wiki won't know about the files, unless you copy across the old database (as well as the wiki files) - or maybe Category:Bulk_upload will help.

Reply Edited 21:15, 13 April 2021 10 hours ago Permalink This post was hidden by Jonathan3 ( history ) Reply to "Move the images folder" [SMW] Embedded queries are not auto updated 2 comments • 21:13, 13 April 2021 10 hours ago 2 Edit title History Permalink Summarize 92.89.123.253 ( talk contribs )

Hello,

I am facing an issue with Semantic Mediawiki embedded queries [,"dsr":[70,82,null,null]}" data-mw="{"parts":[{"template":{"target":{"wt":"#ask:...","href":"./Topic:W7186v4f9kemp3wk#ask:..."},"params":{},"i":0}}]}"> {{#ask:...}} on my wiki with Mediawiki 1.35.1 and Semantic Mediawiki 3.2.3.

Queries are working fine but their displayed result are not automatically updated even when their *actual* results change (i.e. the retrieved data change as a result of some modifications on queried pages). I can force the update by purging the query page, but I have multiples queries accross my wiki and this is not a long term solution.

I have disabled all caching mechanisms (wgMainCacheType, smwgMainCacheType, smwgQueryResultCacheType) and non-default extensions, without any visible improvement.

Yet if I execute the SQL I get from {"k":"format","named":true},"dsr":[688,713,null,null]}" data-mw="{"parts":[{"template":{"target":{"wt":"#ask:...","href":"./Topic:W7186v4f9kemp3wk#ask:..."},"params":{"format":{"wt":"debug"}},"i":0}}]}"> {{#ask:...|format=debug}} , everything is fine. I don't know how to go further   :(

Any idea on how I could fix this?

Reply 20:35, 13 April 2021 11 hours ago Permalink Jonathan3 ( talk contribs )

I use Cargo rather than SMW but would Extension:MagicNoCache help you?

Reply 21:13, 13 April 2021 10 hours ago Permalink Reply to "[SMW] Embedded queries are not auto updated" Scratch Wiki skin issue One comment • 19:56, 13 April 2021 11 hours ago 1 Edit title History Permalink Summarize Plastacikec ( talk contribs )

Hello, so I wanted to install the Scratch Wiki skin on my wiki, I loaded it using wfLoadSkin( 'ScratchWikiSkin2' ); but when I set it as a default skin and try to visit the wiki, it displays a 500 HTTPS error for some reason. Is there a way on how to fix this?

Reply 19:56, 13 April 2021 11 hours ago Permalink Reply to "Scratch Wiki skin issue" Search results for other wikis 2 comments • 18:55, 13 April 2021 12 hours ago 2 Edit title History Permalink Summarize Kanasalaatti ( talk contribs )

I have my own wiki farm, multiple wikis, and I would like to enable it so that when I search for something on a wiki on the Special:Search -special page, it shows similar results from other wikis. We have CentralAuth up and running and the wikis are connected.

What setting should be on for the search function to show results from other connected wikis?

Reply 16:47, 13 April 2021 14 hours ago Permalink Bawolff ( talk contribs )

The wikimedia version is part of extension:CirrusSearch but prob requires additional setup i dont know about.

Reply 18:55, 13 April 2021 12 hours ago Permalink Reply to "Search results for other wikis" Templates 3 comments • 18:54, 13 April 2021 12 hours ago 3 Edit title History Permalink Summarize Plastacikec ( talk contribs )

Where can I get the templates like This page in a nutshell, or a Stub template?

Reply 17:34, 13 April 2021 14 hours ago Permalink Tanbirzx ( talk contribs )

At first you should go to a page with source editing option then you will see a function bar top of the page. In there you can find a search box for template.

For external help-

See Help:Templates#Linking to a template

Reply 18:09, 13 April 2021 13 hours ago Permalink Bawolff ( talk contribs ) Manual:Importing Wikipedia infoboxes tutorial Reply 18:54, 13 April 2021 12 hours ago Permalink Reply to "Templates" Load more Retrieved from " https://www.mediawiki.org/wiki/Project:Support_desk "Navigation menuPersonal toolsNot logged in Talk Contributions Create account Log in Namespaces MediaWiki.org Discussion VariantsViews View history MoreSearch
Navigation Main page Get MediaWiki Get extensions Tech blog Contribute Support User help FAQ Technical manual Support desk Communication Development Bug tracker Code docs Code repository Statistics MediaWiki.org Community portal Recent changes Translate content Random page Village pump Sandbox Tools What links here Related changes Upload file Special pages Page information Print/export Create a book Download as PDF Printable version In other languages Add links Text is available under the Creative Commons Attribution-ShareAlike License ; additional terms may apply. See Terms of Use for details. Privacy policy About MediaWiki.org Disclaimers Code of Conduct Mobile view Developers Statistics Cookie statement Wikimedia Foundation Powered by MediaWiki
© 2014-2021 ЯВИКС - все права защищены.
Наши контакты